cdylib crates for C interoperability

Minimum Rust version: 1.10 for rustc

Minimum Rust version: 1.11 for cargo

If you're producing a library that you intend to be used from C (or another language through a C FFI), there's no need for Rust to include Rust-specific stuff in the final object code. For libraries like that, you'll want to use the cdylib crate type in your Cargo.toml:

[lib]
crate-type = ["cdylib"]

This will produce a smaller binary, with no Rust-specific information insde of it.